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The Art of Efficiency: lllustrator Tips from a Japanese Master

All of the demo files, scripts, and more can be downloaded from
http://bit.ly/adobemax-aoe
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1. Presentation Mode / Trim View

*new to Illlustrator CC 2019*

Presentation Mode

- View > Presentation Mode
. Screen Mode (on the bottom of Tool Panel)
- shift-F

Trim View

View > Trim View
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Four good things about using Symbols

1. Light data: Creating multiple instances doesn't increase document size

2. Safe: Accidentally editing an instance doesn't mess up the Master Symbol data

3. Easy to edit and changes apply all: Apply a change to the Master Symbol across all instances with one click

4. Easy to replace: can replace Symbol instances with a different Symbol instantly
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To use Symbols:

1. Window > Symbols to open the Symbols Panel

2. Select your graphic. Drag the graphic into the Symbols Panel. Name it (option-
al).

3. To place instances of the created symbols, drag from the Symbols palette.
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Symbol Options

Name: 7-11
Export Type: Movie Clip v
Symbol Type: O Dynamic Symbol
O static Symbol

Registration: §§§
[ Enable Guides for 9-Slice Scaling
@ "Movie Clip" and "Graphic" are tags for Flash

import. There is no difference between these two
symbols in Illustrator.
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To replace Symbols

1. Select symbol

2. Click Replace Symbol icon in Properties Panel, then click other symbol icon.

[ @ Art of Efficiency Tip (select same instance) J

If you want to select same symbol instance as you selected, select the Symb
Instance,

Select > Same > Symbol Instance

[ @ Art of Efficiency Tip (Reselect) J

command + 6 (Ctrl + 6) will reselect.

[ @ Art of Efficiency Tip (rotated text) J

When an artwork will be rotated, register the original as a Symbol and rotate
the instance. Any changes can be made to the master and applied to the
instance while maintaining the angle of rotation. Also, proofread on the
non-rotated master for ultimate efficiency!
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Symbols
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Dynamic Symbols

Once you change Symbol Type to “Dynamic Symbol’, you can select parts
of the symbol instance with the Direct Selection tool, and change fill, stroke,
opacity, and effect (such as Drop Shadow).

With Dynamic Symbols, Symbol instances can have different appearances
such as fill, stroke, and opacity without breaking its link to the master symbol.
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Replace Symbol: w 2

Break Link

Recolor

Replace Symbol feature

&) VZZId SONANE,
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even this can be registered as a Symbol:
Just rotate the instances

Duplicate Symbol
Delete Symbol
Edit Symbol

ERG IRC | Place Symbol Instance

Select All Unused
Select All Instances

Sort by Name

v Thumbnail View
Small List View
Large List View

Symbol Options...

Open Symbol Library >
Save Symbol Library...



3. Symbols & 9-Slice Scaling

Sometimes you want to stretch artwork without affecting the edges. To scale
artwork while protecting certain areas, register the artwork as a Symbol and
use 9-slice scaling.

To use 9-slice:

1. Select Enable Guides for 9-Slice Scaling in Symbol Options when creating or
editing a Symbol

2. Double-click the new symbol in the symbols palette to position the guides to
define what areas will be stretched or scaled, and what areas will be protected.
Click Escape to set the guides.

[ NON ) B all-2.ai* @ 150% (RGB/GPU Preview)

3. Click on the artwork and drag handle to resize. The middle row and column
will expand or contract without affecting the edges.

[ @ Art of Efficiency Tip J

Registering artwork as Symbols with 9-slice scaling can be really useful for web
graphics and other repeating designs.
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Symbol Options

Name: window
Export Type: Movie Clip v

Symbol Type: O Dynamic Symbol
© static Symbol

Registration: §E§

Enable Guides for 9-Slice Scaling

@ "Movie Clip" and "Graphic" are tags for Flash
import. There is no difference between these two

symbols in Illustrator.

( Cancel )(
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[ @ Art of Efficiency Tip J

If your artwork contains text, follow these steps because text doesn't scale well
with 9-slice. BEFORE registering the artwork as a Symbol, select the artwork,

Effect menu > Path > Outline object.

Then follow the steps above to register the artwork as a Symbol, making sure
the text is in the non-scale area.

Because the object and text is outlined though the Effects menu, it is non-de-
structive and the text can still be edited.

Q Search

[ B Art of Efficiency Script J

lllustrator doesn't support one-click replacing multiple pieces of artwork to
Symbols. But you can use Toshiyuki Takahashi’s Convert to Symbols Script to
replace your artwork to Symbols in a single step.

Link: https://github.com/gau/object-to-symbol

Switch selected artwork to Symbol - ver.0.5.6

Symbols:

7-11

( Crvad ) ( Replace )
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4. Global Editing

*new to Illlustrator CC 2019*

Another way to efficiently make changes across multiple objects is brand-new
to CC 2019: Global Editing. Global editing will find and select similar objects,
such as artwork that has been copied & pasted and then tweaked.

Jenus )

(pz0

To use Global Editing: Quick Actions

Ungroup Isolate Group

1. Select an object.

Save as Symbol Recolor

2. At the bottom of the Properties panel in the Quick Actions section, click the
down arrow next to Find to Edit.

Arrange

Stop Global Edit

3. Select whether to find objects matching Appearance, Size, or both, and where Result(s) (8 objects highlighted)
to search for the objects such as across artboards, whether to include objects Match
on canvas, etc. [ Appearance
[ size
4. Click Find to Edit. All similar objects will be selected and outlined in blue. On Artboards
Changes made to the originally-selected object (outlined in red) will be auto- QSclecill Al Artboards v
matically applied to all selected similar objects. O Range:

Include Objects On Canvas

5. Click Done.

[ @ Art of Efficiency Tip J

Global Editing is sequence-based. Remember to select your base object first
and click the Find to Edit button before applying edits.
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[ @ Art of Efficiency Tip ]

Global Editing can be accessed from the Select menu:
Select < Start Global Edit
And a keyboard shortcut can be assigned to Global Editing if you wish.

[ @ Art of Efficiency Tip J

Global Editing is a cool feature, but Symbols are still useful:

Global Editing Symbol
Light data v
Safe v
Easy to edit and changes apply all v v
v

Easy to replace

[ B Art of Efficiency Script J

When designing similar objects containing text, such as web navigation but-
tons, use Auto-Distribute Text & Boxes script by Goro Shibuya to quickly create
the buttons

PRODUCTS ACCESS

HOME FAQ

fect Type Effect View Window Help
v Object city: | 100%
— Al BA
All on Active Artboard  \_$8A
Deselect T BA
Reselect 36
Inverse 4|
Next Object Above 8]
Next Object Below [
Same >
Object >
Start Global Edit
Save Selection...
Edit Selection...
CONTACT
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5. Recolor (aka Live Color)

Rather than changing Fill and Stroke colors separately, Recolor is a fast way
to change one color to another regardless of what's a Fill color and what's a
Stroke color. You can also use Recolor’s powerful Link Harmony Colors feature
to adjust tonal colors across the selection.

To use Recolor:

- From the Control panel > Recolor Artwork icon
« From the Color panel > Recolor button at bottom of the Color panel
- To change colors one by one, select the Assign tab.

1. To change colors across the selection, select the Edit tab.

Recolor Artwork

O o emnm i v Anwork colors 2
%5 S T 3 ﬁﬂ Assign

o5 IS0 o

- 8 ¥

D3GR o
£

I
None
© 3.3 % = EH.
M - 54 %
Y e (31,49 |%
K gm0 %
Recolor Art

[ @ Art of Efficiency Tip ]

Recolor can be undone immediately after OKing but is a permanent change.
Before using Recolor make a copy of your Artboard so you have an original.

Make sure both options are checked:

« [Move/Copy Artwork with Artboard] option in
control panel
Type Select Effect View Window Help

= X: 960 px

| Name: Artboard 1

« [Move Locked and Hidden Artwork with
Artboard] option in Preference pane

Preferences

General Selection & Anchor Display
Selection & Anchor Display

Selection

Type

Units Tolerance: 3 px
Guides & Grid

Smart Guides

Slices Snap to Point 2 px

[0 Object Selection by Path Only

(i e Command Click to Select Objects Behind
Plug-ins & Scratch Disks

[J Constrain Path Dragging on Segment Reshape
User Interface

PR [0 Show Anchor Points in Selection Tool and Shape Tools
File Handling & Clipboard [ Zoom to Selection
“RpeaEnEs HE sk Move Locked and Hidden Artwork with Artboard
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| @ Art of Efficiency Tip |

To restore a single color to its original after changing color tone across the

selection, select the Assign tab.

Clicking through the Current Colors will highlight the area of the artwork
assigned that color. Simply drag the Current Color onto the New color to

restore the original color.

[m;

Recolor Artwork

| @ Art of Efficiency Tip |

D ﬂ.ll -.- -I ~  Artwork colors Vd

Edit [JASSiGAN
Preset: Custom ~ B colors: T All &
Current Colors (60) New =
d— G
[ =
[ VN d—"
-
b =
T
N - e,
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Y & — |0 %

The Eyedropper tool in the upper right hand of the Recolor Artwork dialog
isn‘t a normal lllustrator eyedropper! It behaves like an Undo button. Clicking
the eyedropper resets the artwork to its un-recolored state. Use with caution
— but it's useful if you need to undo changes without canceling the dialog.

Just remember it's not a normal eyedropper tool.

6. Puppet Warp

When you select the Puppet Warp tool from the Tools panel, lllustrator auto-

matically add pins to the artwork.

You can add more pins or delete pins added by lllustrator to transform your

object.
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7. Freeform Gradients

*new to Illlustrator CC 2019*

lllustrator CC 2019 features a new type of gradient, Freeform Gradients, and an
eyedropper tool so users can select an exact color to use in gradients.
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former Ul on left; new 2019 Ul on right with Freeform Gradients and new gradient eyedropper

Points: Create gradient color stops to shade the area around the point you've
added using the Gradient tool. To adjust the shading area of a gradient color
stop, drag the dotted circle around the gradient color stop.

X

¢ Gradient

[ ~=om

Draw: @ Points O Lines
L wow
Opacity: 100% v

Spread: 60% ~

Lines: Create gradient color stops in a line to shade the area around the line
you've drawn using the Gradient tool.

X <

¢ Gradient

[ ~uaz

» Draw: O Points @ Lines

[ @ Art of Efficiency Tip J

Don't forget Gradients don't work with Recolor.
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8. Font Menu changes

*new to Illlustrator CC 2019*

- Drop-down list showing sample text for font preview. You can also select a text in the artboard for pre-

view. You can change font size for font preview.

- Apply Recently Added Filter icon to show only the newly-added fonts.

- Add to Favorites icon (star) now shows up on the right side of the font menu on mouse over.

x «

¢ Character

|D. Myriad Pro V|

Filter: All Classes v w* =
Y¢ > Myriad Pro (O Sample &S
Y¢ > Acumin Variable Concept (i Sample
Y > Minion Variable Concept (3 Sample
Y¢ > Myriad Variable Concept (3 Sample
Y¢r > Skia (i Sample
Y¢ > Source Code Variable (3 Sample
Y¢ > Source Sans Variable (i Sample
Y¢ > Source Serif Variable (3 Sample
w System Font (i Sample
w Apple Color Emoji H @90
w EmojiOne e @24
w Aktiv Grotesk Sample
w Alternate Gothic No2 D Sample
¥ > Annle Rraille B -

< screenshot showing old font menu >

New Ul for filtering Classification and Properties

x

© Character
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Fonts  Find More

X «

¢ Character

ID. Myriad Pro [x] Vl
Fonts Find More
Filters: Yv % O & Selected Text = lz‘ A
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Zapf Dingbats Se o< -

®0O0Omo xO.e0 200«

Lorem ipsum dolor sit amet; ¢

Wingdings
IR v 2 PréN (6)
P22 Sneaky Pro
Pacifico (3)

Lorem jpoum dolor wit amet, =5y
Sorem ipoum dolor oil amek, conseclelues

Source Code Variable (14) Lorem ipsum dolor sit
Adobe Clean (10)

Domus Titling (7)

Lorem ipsum dolor sit amet, cc

LOREM IPSUM DOLOR SIT A

< screenshot showing 2019 font menu >
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You can now click the Find More tab to view the fonts from Typekit.
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o Myriad pro [x]
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| Fonts. Find More
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Selected Text

@ Activate Adobe Fonts Instantly

Aaux Next (16)
Abadi MT Pro (14)

Abigail Regular

Abolition (4)

Abril Display (10)

Abril Fatface (2)

Abril Text (10)

Abril Titling (8)

Abril Titling Condensed (8)
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Bonus: Art of Efficiency Scripts from Japan’s lllustrator Community

Create Sequential Numbers by Hiroyuki Sato

- Script name: Fixing Sequential Numbers.js

- description: http://shspage.blogspot.com/2009/06/fixing-sequential-numbers.html

- Create sequential numbers from 1 to x very quickly.

Replace with Symbol by Toshiyuki Takahashi

- Script name: switch_selected_artwork_to_symbol.jsx
- description: https://github.com/gau/object-to-symbol

« Illustrator has no automatic mechanism for replacing multiple groups of artwork with a
symbol. Easily batch replace selected artwork with a symbol, and make subsequent editing

a breeze. This script honors the artworks' center point, maintaining position.

Auto-Distribute Text & Boxes by Goro Shibuya of Gorolib Design

- Script name: us03_fitToTextBox2.jsx
- description: https://note.mu/gorolib/n/n5c1df4b62d44

- Create a number of text strings with desired content; now create boxes (shapes) the text
will go in. Select all and run the script. Each text string will be neatly placed in a box, and the

boxes auto-distributed and auto-aligned to create a neat row.

Increment/Decrement Numbers by Goro Shibuya of Gorolib Design

- Script name: us01_CountUp.jsx/us02_CountDown.jsx
- description: http://gorolib.blog.jp/archives/70401627.html

- Select text and run the script. Numbers in text will increase/decrease.

SPAi(Script Panel for Illustrator) by Monokano (Mac only)
- Application name: SPAi.app
- description: http://tama-san.com/spai/
Add panel to lllustrator to manage script. Also you can add Keyboard Shortcut.

Fill with Random Color Values by PICTRIX

« Script name: RndColor.jsx
- description: http://hamfactory.net/illustrator/24h_ai_script/ by PICTRIX

- Set number of colors, define how closely the other colors should be, and set random opaci-

ty.
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